Firmware 0.6.0 - Does it work?

I just compiled and uploaded the last firmware (with bus masked filter command 0x03 0x01 0x02 ....), but it seems not working well. System info and EEPROM commands work (0x01), but no packets, buffer overflow errors, no filters, etc.
Does anybody used it successfully ?
Which are the libraries that must be compiled ? I used these "CANBus, EEPROM, QueueArray, SoftwareSerial, SPI, Wire", is it correct?

The information provided here should get you to the stage where you can start seeing some packets;

Make sure you are compiling using 1.6 of the IDE, I ran into errors using the latest version. Download the older one. Hitting compile on the latest source from github will compile all those libraries you mentioned.

Thank you for infos.
I installed 1.6.0 and the result is the same as 1.6.5: I compile and upload CBT 0.6.0 to the device, but no packets at all; 0.5.0 instead works using arduino 1.6.0 and arduino 1.6.5 both, even if I receive a lot of buffer overflow, while 0.4.6 works perfeclty.

So where are you connecting to? OBD2 Port? What car is it? Have you tried to locate some CAN H and L wires behind the stereo or tachometer?

Connecting to OBD2 port, car is a NISSAN Qasquai 2007, canbus 11bit. Using 0.4.6 it perfectly works, problem only with 0.5.0 and 0.6.0

Makes me wonder if I should go back to 0.4.6, maybe I won't have problems sending CAN packets. I can see logged CAN messages fine on 0.6.0 however, make sure the baud rate is being detected properly. Did you make any further progress with troubleshooting this?

4.6 is the latest that works for me. 2008 Ford Super Duty Diesel

firmware 0.6.0 is broken for me too. Using with high speed GMLAN (500k) on late model GM truck/SUV bus. Doesnt log or anything. I might get a split second log of a couple frames when I select "auto detect bitrate", but otherwise it doesnt log. If I set it manually to 500k, it doesnt log either.

I couldnt find 0.4.6 anywhere, so Im back on 0.4.0.


0.6.0 was contributed by someone on Github. I've noticed some of the issues you guys are seeing and I am in the process of figuring it out.

You can easily switch back to 0.4.6 for now using the new Boards Manager functionality:


So for reference the API did change a bit in 0.6.0 by a contributor. The command to log packets changed (for the better)

I'm working on updating the app for compatibility and continuing to work on the android app as well.

See the comments here:

Enable/disable logging over serial (filters are optional)

Cmd Bus On/Off MsgId1 MsgId2
0x03 0x01 0x01 // Enable logging on bus 1 (do not touch current filter)
0x03 0x01 0x01 0x290 0x291 // Enable logging on bus 1 and filter only messages 0x290 and 0x291
0x03 0x01 0x00 // Disable logging on bus 1
MsgId1 Mask1 MsgId2 Mask2
0x03 0x01 0x02 0x290 0xFFF 0x400 0xFF0 // Enable logging on Bus 1 filter messages 0x290 and 0x40* (0 in mask is a wildcard)
0x03 0x01 0x02 0x000 0x000 // Enable logging on Bus 1 for ALL messages

  • 10
  • 9926

Looks like your connection to CANBus Triple was lost, please wait while we try to reconnect.