VW Polo 6R (MK5) not responding to own messages

Hi all,

I've connected to the convenience bus (green wire) right by my canbus gateway in my Polo 6R and I do see all the messages on the bus fly past so that's working well and all.

I've figured out the ID for the steering wheel buttons and I am able to replay it and my radio indeed does respond to it, however... When I send for example a message for the wipers my car does not respond to it at all. Blinkers, headlights, door locks, etc... Nothing else will respond.

I'm a bit baffled now because I was connected to the bus right behind my radio before but moving down the tree to right before my canbus gateway it still doesn't seem to work.

Has anyone else worked on a VW MK5 model that could give me some insight into my problems and how to make it work?

last edited by Zunz

I had this exact problem on my 03 plate CL55. Radio works and even some window controls but lights, door locks, other interior buttons etc, no luck. It might have something to do with the part of the convenience bus you are connected to, are you able to try CAN cables in a different location? I never did figure it out but I was planning to give it another decent attempt when I change my car later this year. Part of me thought it could be that you need to read 29-bit CAN messages.

Derek mentioned to me once that; the messages you see may be the understood/response message and not actually the message sent to trigger the action, you may not see the original message on the CAN you are connected to. Let me know if you make any progress!

  • 2
  • 3655

Looks like your connection to CANBus Triple was lost, please wait while we try to reconnect.