"can't set com-state..." error when uploading to CANBus Triple

When I try to upload a sketch (including the "Blink" example) to my CBT, I get the following error:

avrdude: ser_open(): can't set com-state for "\.\COM10"
avrdude: ser_send(): write error: sorry no info avail

I'm using Arduino 1.6.0 on Windows 8. I verified that I can upload the "Blink" from My Computer to an Arduino Leonardo board using either the "Arduino Leonardo" board type or the "CANBus Triple" board type. I've also verified that COM10 is the correct COM port by making sure it appears when I connect my CBT, and disappears when I disconnect my CBT.

One thing I noticed, which may or may not be significant, is that my Arduino Leonardo board fist connects as "Arduino Leonardo bootloader" before disconnecting and reconnecting as "Arduino Leonardo" after a few seconds. When uploading to the Leonardo, the Leonardo also disconnects and reconnects as "Arduino Leonardo Bootloader. The CBT connects as "Arduino Leonardo" immediately when plugged in, and does not reconnect when I try to upload a sketch.

Any idea what to check next?


Arduino IDE will send a reset (usually by connecting at 1200bps) to tell the running program to reboot into the bootloader then it will attempt to flash. I've noticed on windows it will assign a different COM port to the bootloader as it does to the running sketch.

I'll try the new Arduino on windows 8 when I get home. I usually use Linux and Mac but I have a utility windows 8 box.

For what its worth, I just tried to upload the blink example to the CBT using Arduino 1.6.0 on a Windows 7 computer and 1.0.? on a Linux computer with the same result.

I had this same problem. After installing and removing Arduino 3 times the CBT began to funtioned correctly. I was observing the USB Driver Sofware Installation window after a fresh Arduino install.
Not all of the Drivers were installing and for some reason and on my third Arduino installation attempt I got all green check marks device behaved correctly.
No more:
avrdude: ser_open(): can't set com-state for "\.\COM10"
avrdude: ser_send(): write error: sorry no info avail.....

  • 4
  • 6454

Looks like your connection to CANBus Triple was lost, please wait while we try to reconnect.