The downloads page doesn't have links. The source is on github.
Are we supposed to build the app ourselves?

I got my CBT today and want to get to figuring out how to read from my Chrysler T&C.


I'm still finishing up the app, sorry for the delay. Right now you have to dump packets over USB Serial. For more info on that see here:

Once the app is ready for beta I will post downloads and push it to app stores. Right now I wouldn't worry about building it from source unless you really have some time to kill. :)

Got it. So in the mean time, can I just hook up a laptop and terminal program and try to view the data stream from the vehicle? Is there enough in place for that?


Yeah totally. I know it's a pain but until the app is ready that's what we have. You can modify the base firmware to do stuff your way too if you have ideas.

I cleaned up and updated the app, made it easier to build etc last night. I'll hopefully be able to release the alpha of the desktop version shortly.


Got a lot done this weekend. Going to test on all desktop platforms and post beta downloads hopefully tonight or tomorrow. I got sidetracked a little and wrote an adapter to feed packets into Wireshark for people who want that. It will be integrated into the desktop app as well!

Had a look at the Wireshark part but to much trouble for me. I'm more of a car guy than a programmer ;-)

Looking forward to the apps!

Followed the instructions for Wireshark. I can run the node.js app, it creates the /tmp/cbtbus1 pipe (works only when run with sudo). When I start Wireshark and add the interface all seems well. But when I start the capture process I get the message "The capture session coud not be initiated due to error on socket connect: Connection refused". I tried running Wireshark as root (start with sudo from command line) or change the permissions on /tmp/cbtbus1 but none of this gets me passed the error.

When I start the node.js app as a normal user I get this error:
Socket bound: /tmp/cbtbus1

throw er; // Unhandled 'error' event
Error: Cannot open /dev/cu.usbmodem641

When run with sudo it creates the pipe but Wireshark returns 'connection refused'.


I assume /dev/cu.usbmodem641 is the correct path? When you have the CBT plugged in run 'ls /dev/cu.usb*' and it should list your usb serial devices.

Make sure you're not connected to the CBT with other software or it will not work.

Yes, I checked the path which is correct and I am not using any other software...

@henk_kuipers: My CBT was listed under /dev/ttyACM0 which is where all my serial devices seem to show up (Ninja Sphere, USB 56k modem etc.). I'm on Ubuntu 14.04 LTS with no other software (that I know of) connecting to the CBT

Hi Grayda, the path in of the serial device is not the problem. The node.js app runs and creates the pipe /tmp/cbtbus1 correctly. Also, when the path to the serial device is incorrect, the node.js app won't start, which it does. There seems to be some problem with the rights / access but haven't figured out what.


What platform are you on @henk? I made some updates to the code, give it another go and maybe try running node with sudo if you're on unix.

@Derek I am running it on OSX Yosemite, npm version 2.7.5, node v0.12.2 and I cloned the latest code today. The problem is the node app starts up when I run: node index.js /dev/cu.usbmodem411
and it returns:
Socket bound: /tmp/cbtbus1
Socket bound: /tmp/cbtbus2
Socket bound: /tmp/cbtbus3
Logging enabled on all three busses
But then it exits, without any error message. It should stay running shouldn't it? The cbtbus1-3 files are created in /tmp.
Somehow, there is a problem in my environment :-/ I tried it with a friend on another OSX machine and it ran fine.

Any update on the apps? I can see there is being worked on but while some may be able (and willing) to generate their own apps from code I would be more interested in trying one of the finished ones. Either Windows or Mac would be fine.



@henk_kuipers‌ That's odd, I'm testing on node 0.12.0 I'll try 0.12.2

Had a look at the apps. I've got two old XP laptops for fiddling with my cars. Is there only a 64 bit windows version?


@Derek, switched to Windows 8.1 64 bit. Works well!

  • 20
  • 16842

Looks like your connection to CANBus Triple was lost, please wait while we try to reconnect.