I installed Arduino IDE and followed the setup instructions and all seemed to be fine. When I first plugged my CBT in, Windows 10 recognised it as an Arduino Leonardo but since that first time, Device Manager shows it as Arduino Leonardo Bootloader and then after a few seconds it just disappears. I tried it again from scratch on Windows 8 with a clean install of Arduino and a new clone from github but just get the same brief Arduino Leonardo Bootloader device and then nothing. Any ideas? Thanks, Matt

administrators

Are the LEDs blinking? The red led will dimly pulse in bootloader mode and then flash three times when it runs the main code.

Let me know and we can go from there

HI Derek - a blue LED flashes once when I plug it in and then there's a dim green light but nothing else.

administrators

So you get the adruino bootloader com port and then after 8 seconds it goes away and no other com port appears in windows 10?

Maybe the eeprom got corrupted. I'd suggest removing the board from the case so you can press the reset button. Plugin the CBT via usb and then press reset button and quickly hit upload in arduino.

I originally tried it on Windows 10 but have since been using Windows 8.1. When I plug in the USB lead, the blue LED flashes briefly and the green LED comes on continuously (but dim). In Device Manager, 'Arduino Leonardo bootloader (COM3)' comes up under Ports (COM & LPT) but that disappears after 7 or 8 seconds and nothing else comes up.

I'll try doing an upload after hitting the reset button and see how I get on.

Thanks, Matt

OK - big step forward, thanks Derek. I had previously tried to upload from Arduino whilst the bootloader device was connected but presumably wasn't quick enough. This time I started the upload process just before I pressed the reset button and it seems to have worked.
I now have a solid 'Arduino Leonardo (COM4)' in Device Manager and the red LED does its pulsing and three flashes when I plug it in. Do I need to I worry that it shows as a Leonardo in device manager? Will I need to flash the firmware from github or should it already be up to date?
It connects to CoolTerm on COM4 and I tried sending 0x0101 at 57600 baud but got nothing back - I thought I'd have seen something even if it's not connected to the OBD2 port - is that correct?
Cheers, Matt

I worked on the basis that I would need to flash the firmware as there are two versions (and there would presumably be no problem re-flashing). I got an error message as below:

avrdude -Cavrdude.conf -v -patmega32u4 -cavr109 -PCOM4 -b57600 -D -Uflash:w:CANBusTriple.cpp.hex:i

avrdude: Version 5.10, compiled on Jan 19 2010 at 10:45:23
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

     System wide configuration file is "avrdude.conf"

     Using Port                    : COM4
     Using Programmer              : avr109
     avr910_devcode (avrdude.conf) : none
     Overriding Baud Rate          : 57600
     AVR Part                      : ATmega32U4
     Chip Erase delay              : 9000 us
     PAGEL                         : PD7
     BS2                           : PA0
     RESET disposition             : dedicated
     RETRY pulse                   : SCK
     serial program mode           : yes
     parallel program mode         : yes
     Timeout                       : 200
     StabDelay                     : 100
     CmdexeDelay                   : 25
     SyncLoops                     : 32
     ByteDelay                     : 0
     PollIndex                     : 3
     PollValue                     : 0x53
     Memory Detail                 :

                              Block Poll               Page                       Polled
       Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
       ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
       eeprom        65    10     8    0 no       1024    8      0  9000  9000 0x00 0x00
       flash         65     6   128    0 yes     32768  128    256  4500  4500 0x00 0x00
       lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
       signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

     Programmer Type : avr910
     Description     : Atmel AppNote AVR109 Boot Loader

Connecting to programmer: .
Found programmer: Id = "O ("; type = ]
Software Version = D. ; Hardware Version = ­.´
avrdude: error: buffered memory access not supported. Maybe it isn't
a butterfly/AVR109 but a AVR910 device?

administrators

The bootloader implements a subset of AVR109. The CBT bootloader will actually identify itself as such:

<blockquote>Found programmer: Id = "CANBusT"; type = S</blockquote>

Are you flashing from the command line? Maybe is an avrdude.conf issue. It definitely works with the avrdude binaries in Arduino 1.6.0.

Hi Derek - thanks for your help. After much messing around with different cables, ports and FIFO settings, I decided to just try re-uploading from Arduino after I'd upgraded to v1.6.1 and all now seems to be fine. I'm not entirely sure what changed but it is now working and that's all that matters. Cheers, Matt

FYI -- I had something similar happen to me today immediately after uploading an updated sketch. I followed the instructions in this thread, pressed reset on the CBT, saw the port show up (OS X here) and quickly uploaded.

Back in business, but I was sweating it there for a few.

I'm throwing away the Mini USB cable that came with my CBT. I suspect that's what caused the bad write.

  • 10
    Posts
  • 3646
    Views

Looks like your connection to CANBus Triple was lost, please wait while we try to reconnect.