CANBus Triple Desktop app - alpha release

@Grayda‌ If you run the packet logger in 'Compact' mode it does group by message ID. This is the default mode. What I've been doing is just logging and watch for a line in the table to change when I press a button in the car.

Help me understand a little better how I could make the workflow easier. Thanks!

OSX problems solved, one of my USB cables appeared to be bad. App & Wireshark work fine now on both Win64 and OSX Yosemite.

Bump on the update status.

"Send command" is blocking sometimes the app on OSX Yosemite.
Which format I should use to send commands there? Can you put some example in app as placeholder so new user can get should they just send message id + data or full format?


A new build for Mac is up and window / linux will be once I get all the libraries built on those platforms.

Thanks Derek.
I finally upgraded to Win8.1, so got to briefly check out the app today. Looks good, easy to navigate.
Did have a issue when attempting to upgrade Firmware from .4.2 with it. CBT rebooted but the app hangs at uploading firmware. Have to close and reopen it when that happens. I haven't had time look into it further yet.

Is the old version available somewhere? Seems like the wireshark packet pipe is broken in the current version (tried in Windows and OSX). If I click the button, the program locks up.

I know this thread is very old but what happened to the iOS app? Cannot locate how to get it. :(


I was working on a hybrid app for android/ios but was unhappy with the performance. So I started working on an Android app and that is still in progress. I'm leery on iOS because I'm starting to dislike Apples business practices.

Just to add I am having some issues with the Mac app. If I start up fresh, then plug in USB for the CBT. Boot up the app. Press logger and connect via USB. I then plugin my ribbon cable and no logging. If I then unplug the ribbon and USB and open CoolTerm plugin USB, connect. Run 030101 then plugin ribbon. I get flooded with data. I disconnect from CoolTerm and switch to CBT App then tell it to connect via USB again. At that point I will see data in the CBT app just fine. If I turn on the wireshark piping logging stops. Also there doesn't appear to be any sort of log dump from the CBT app, I assume because we would choose to do that with Wireshark. So I am kind of stuck at this point with the app. I will have to see about tracking down a windows laptop to see if I get different results there.


Hey Mamunoz,

The community on Github made an api change on 0.6.0. I pushed a new app last week that should log correctly, the app version is 0.3.2. Are you on 0.3.2? Maybe the fix needs more fixing!

I will check which version is on my laptop when I get home from work tonight and report back.

Yeah I was running 0.3.1 I will try 0.3.2 on my way into work tomorrow.

OK got some time to test this some more. 0.3.2 is far more reliable with logging packets in the app. No longer any funny business with CoolTerm required to kickstart it. However pipes are not working. I go to the tab hit start. Fire up WireShark. Command+K hit manage interface add /tmp/cbtbus1 and start the capture and its just flooded with blank packets. Similar to what the app was doing before I updated.

I am not sure if this is the correct place to post this, but here goes. I just recently received my CBT, but I'm having issues connecting it to the app. I have attempted to connect/flash the CBT on both Windows 7 and 10 64 bit, and both seem to never get any data from the CBT(it just has a circular loading icon and never displays the version etc). Any help would be appreciated

Ok, so after disconnecting and reconnecting around 50 times the CBT seems to connect. I believe the usb cable it came with is defective as it powered on with a different cable that I had. I haven't had a chance to see if it will stream data from the car as it's 3:35 in the morning and my neighbors would probably not be too happy, but I assume everything works as it should.

  • 28
  • 32272

Looks like your connection to CANBus Triple was lost, please wait while we try to reconnect.