CANBus Triple Desktop app - alpha release

Hey All!

I've been hard at work on the app for weeks now. It's ready for an alpha release so I can get feedback from you. Here are the download links:


Please give it a try and let me know what you think. It has the wireshark pipe integrated so you can easily use wireshark without installing command line utilities.

After launching the app click Hardware in the menu and select the COM port your CBT is attached to.

I am excited for this...thank you for your hard work!

The packet logger and pipe work great so far. The app did seem to stall when I tried updating the firmware with it; compiling and uploading the arduino source of course works fine though.

I extracted the app to my Ubuntu laptop and went out to the car. The flashing portion didn't work (it'd download then hang on the flashing stage. I think it tried to flash, but it still said version 4.2 in the hardware section).

When I flashed to 4.4 via my PC the app worked well. I was able to see packets coming in, though I don't know if the filter worked, as I ticked one of the boxes on the left and had packets still flooding in. Auto baud rate worked, didn't get a chance to try BLE, but I will eventually, as I'm pretty certain I'll need to wire the CBT in to get to the other two CANs

Other than all that, the app looks really good, is easy to navigate and I'm intrigued by the plugins area on the left. Is there any documentation for writing plugins yet, or should I poke through the app source code?

Two feature requests I have, if possible:

  1. Be able to group similar packets (e.g. by ID) or group duplicate packets to make finding the packets we want, easier
  2. A "cheat code" style packet search. To clarify: Some video game console emulators let you search for cheats by comparing states. For example, to get unlimited lives, you open the cheat searcher to get into an initial state. Then you die once. Go back into the cheat searcher and look for a memory value that's decreased since last time you checked. You then play for a bit, die again, then search again for decreased values. Eventually you're left with a handful of memory addresses that you can "watch". When you find one that goes down when you die, that's your lives. You set it to FF and you've now got 255 lives. There are various search modes like "has / has NOT increased / decreased [by Y]" "is / is NOT equal to X" that let you hunt down information of interest.

I installed the app & wireshark on Windows 8.1 64 bit laptop (left the OSX platform, too many problems right now). Works well!

Is bluetooth LE functional in the new app? I'm only able to get USB to work for OSX and Windows (and this laptop is definitely bluetooth LE capable). Haven't tried linux yet

Works great on my win 7 64 bit with wireshark

Same issue here on Ubuntu.


Issue on Ubuntu? I'll look into it.

No BT LE in this release yet. It does work however on the Android and iOS app which I'm working on getting out there asap.


@Grayda‌ If you run the packet logger in 'Compact' mode it does group by message ID. This is the default mode. What I've been doing is just logging and watch for a line in the table to change when I press a button in the car.

Help me understand a little better how I could make the workflow easier. Thanks!

OSX problems solved, one of my USB cables appeared to be bad. App & Wireshark work fine now on both Win64 and OSX Yosemite.

Bump on the update status.

"Send command" is blocking sometimes the app on OSX Yosemite.
Which format I should use to send commands there? Can you put some example in app as placeholder so new user can get should they just send message id + data or full format?


A new build for Mac is up and window / linux will be once I get all the libraries built on those platforms.

Thanks Derek.
I finally upgraded to Win8.1, so got to briefly check out the app today. Looks good, easy to navigate.
Did have a issue when attempting to upgrade Firmware from .4.2 with it. CBT rebooted but the app hangs at uploading firmware. Have to close and reopen it when that happens. I haven't had time look into it further yet.

Is the old version available somewhere? Seems like the wireshark packet pipe is broken in the current version (tried in Windows and OSX). If I click the button, the program locks up.

I know this thread is very old but what happened to the iOS app? Cannot locate how to get it. :(

  • 28
  • 32265

Looks like your connection to CANBus Triple was lost, please wait while we try to reconnect.