Joined
Last Online
Recent Posts
posted in General Discussion read more

Here is the path that has trouble. Un-ziping to a folder at c: that has a single character name (e.g. c:\a) seems to work.

\app.nw\node_modules\cbt-wireshark\node_modules\serialport\node_modules\node-pre-gyp\node_modules\request\node_modules\form-data\node-modules\combined-stream\node_modules\delayed-stream\test\integration

posted in Firmware read more

Additional info. I needed to install a build system on a second computer. I simply installed 1.6.3 and got the same collect2 error I was getting before! It turns out that in fixing the issue before I forgot I had also installed and uninstalled 1.6.2 of Arduino. Repeating that sequence I did the following on the new system.

  1. Install 1.6.3, attempted to compile and got collect2 error
  2. Install 1.6.2, attempted to compile and got a collect2 error
  3. Installed 1.6.3 again. Now things compile.

I am new to Arduino. Could it be installing 1.6.2 then installing 1.6.3 on top of it somehow left something behind that is needed?

posted in General Discussion read more

Just downloaded the Windows version of the desktop app. Windows throws an error while unzipping:

Error 0x80010135: Path too long

combined_stream.js

This happens several times during the unzip process if you select "skip"

The error occurs even when the ZIP file is placed at the root level of the C drive (can't make path lengths any shorter than that)

Mike

posted in Firmware read more

So I uninstalled and reinstalled the IDE several times. No luck. I then installed the previous version 1.6.3 of the Arduino IDE and got a clean compile. Looks to me like there is a problem with the current firmware release and the latest version (1.6.4) of the IDE.

posted in Firmware read more

I downloaded the latest firmware files and the latest Arduino install. When I compile I get the short error below. Enabling verbose I get the long error below.

Any suggestions why I am getting a collect2 error? I have the correct board selected. I am not sure what file is missing. All the files int he last section seem to exist.

Mike

------------------------- short error -----------------------------

Arduino: 1.6.5 (Windows 7), Board: "CANBus Triple"

Build options changed, rebuilding all

collect2.exe: fatal error: CreateProcess: No such file or directory
compilation terminated.
Error compiling.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.

---------------------------- long error (edited because of max length in forum -----------------------

Arduino: 1.6.5 (Windows 7), Board: "CANBus Triple"

Build options changed, rebuilding all

Using library CANBus in folder: C:\Users\mycall\Documents\Arduino\hardware\CANBus-Triple\avr\libraries\CANBus

Using library SPI in folder: C:\Users\mycall\Documents\Arduino\hardware\CANBus-Triple\avr\libraries\SPI

Using library EEPROM in folder: C:\Users\mycall\Documents\Arduino\hardware\CANBus-Triple\avr\libraries\EEPROM

Using library QueueArray in folder: C:\Users\mycall\Documents\Arduino\hardware\CANBus-Triple\avr\libraries\QueueArray (legacy)

<snip>

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc -w -Os -flto -Wl,--gc-sections -mmcu=atmega32u4 -o C:\Users\mycall\AppData\Local\Temp\build3827385021889454149.tmp/CANBusTriple.cpp.elf C:\Users\mycall\AppData\Local\Temp\build3827385021889454149.tmp\CANBusTriple.cpp.o C:\Users\mycall\AppData\Local\Temp\build3827385021889454149.tmp\CANBus\CANBus.cpp.o C:\Users\mycall\AppData\Local\Temp\build3827385021889454149.tmp\CANBus\Message.cpp.o C:\Users\mycall\AppData\Local\Temp\build3827385021889454149.tmp\SPI\SPI.cpp.o C:\Users\mycall\AppData\Local\Temp\build3827385021889454149.tmp\EEPROM\EEPROM.cpp.o C:\Users\mycall\AppData\Local\Temp\build3827385021889454149.tmp/core.a -LC:\Users\mycall\AppData\Local\Temp\build3827385021889454149.tmp -lm

collect2.exe: fatal error: CreateProcess: No such file or directory
compilation terminated.
Error compiling.

posted in Hardware and Wiring read more

I was able to find the eagle.epf file and get the schematic and board to come up in Eagle. I was also able to generate Gerbers.

However there is no joy when it comes to libraries. I was also able to find most of the library files except for

CustomParts_CBT.lbr
can.lbr
molex6pin.lbr
sparkfun.lbr (I found the repo for SparkFun libraries but there was no library named sparkfun.lbr

Any ideas on where the missing libraries could be found?

Thanks in advance.

posted in Hardware and Wiring read more

I see where the Eagle files for the hardware are stored on GitHub but there is no Eagle project file and no library files (for part foot prints). I am not an Eagle wiz but it appears these files are pretty much useless without the project / library files. I hope I am wrong. Advice please.